Possible causes:

  1. Your browser is loading outdated or incompatible content due to cached data.

    Try to resolve the issue by clearing the cache in your browser.

      STEPS  
    • Safari (iPhone, iPad): 
      1. Open the 'Settings' section on your iOS device (gear icon)
      2. Scroll down and tap on 'Safari'
      3. Scroll down again and tap on 'Clear History and Website Data'
      4. Confirm by tapping 'Clear History and Data'

        Note: If you are using a different browser on your iOS device, you can follow a similar process by selecting the respective browser in the device settings and clearing its browsing data.
         
    • Google Chrome
      1. Open the Chrome app
      2. Tap the three vertical dots in the upper-right corner (menu icon)
      3. Scroll down and tap 'Settings'
      4. Tap 'Privacy'
      5. Tap 'Clear browsing data'
      6. Ensure the 'Cached images and files' option is checked
      7. Tap 'Clear data'
         
    • Microsoft Edge: 
      1. Open the Microsoft Edge app
      2. Tap the three horizontal dots in the lower-right corner (menu icon)
      3. Scroll down and tap 'Settings'
      4. Tap 'Privacy'
      5. Tap 'Clear browsing data'
      6. Ensure the 'Cached images and files' option is checked
      7. Tap 'Clear'
         
    • Firefox: 
      1. Open the Firefox app
      2. Tap the three horizontal lines in the lower-right corner (menu icon)
      3. Scroll down and tap 'Settings'
      4. Tap 'Privacy'
      5. Tap 'Clear Private Data'
      6. Ensure the 'Cache' option is checked
      7. Tap 'Clear Data'

  2. Your IP address is blocked. Buddi recently had a system update to block IP addresses outside of Canada for security purposes. The menu will only load on devices within Canada

  3. Your website is not secure. If your website is loading via http:// instead of https://, then you need to purchase an SSL certificate for your domain. This is completed within your web host account (where the domain / website address was purchased).
      
  4. You are using Buddi's old menu script, which needs to be enabled in the back-end of Buddi.
    1. To obtain the new version, sign into the Admin Portal > go to Store Settings > Online Menu: Configuration > copy the script
       
    2. Since the new menu script contains an 'authID' identifying your store, you can remove '?store_id=####' from all menu links on your website.

Article: How come my menu is showing products that I don't have?